ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 
      
ОдноименныеКолонки = Новый Массив();
Для Каждого Колонка Из ИсходнаяТаблица.Колонки Цикл
СовпадающаяКолонка = ТЗПолучатель.Колонки.Найти(Колонка.Имя);
Если СовпадающаяКолонка <> Неопределено Тогда

// Получить свойства колонки.
Индекс = ТЗПолучатель.Колонки.Индекс(СовпадающаяКолонка);
Имя = Колонка.Имя;
ТипЗначения = Колонка.ТипЗначения;
Заголовок = Колонка.Заголовок;
Ширина = Колонка.Ширина;

// Заменить колонки в таблице-получаетеле.
ТЗПолучатель.Колонки.Удалить(Индекс);
ТЗПолучатель.Колонки.Вставить(Индекс, Имя, ТипЗначения, Заголовок, Ширина);

// Добавить очередное имя совпадающих колонок в массив.
ОдноименныеКолонки.Добавить(Колонка.Имя);
КонецЕсли;
КонецЦикла;

// Цикл перебора строк исходной таблицы.
Для Каждого СтрокаИсходнойТаблицы Из ИсходнаяТаблица Цикл

// Добавить новую строку в таблицу-получатель.
НоваяСтрока = ТЗПолучатель.Добавить();

// Заполнить значения в совпадающих ячейках.
Для Каждого ИмяКолонки Из ОдноименныеКолонки Цикл
НоваяСтрока[ИмяКолонки] = СтрокаИсходнойТаблицы[ИмяКолонки];
КонецЦикла;

КонецЦикла;


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.