ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 // Загрузка файлов на FTP сервер
      
Процедура ЗагрузитьОтмеченные(Кнопка)
Сервер = Новый FTPСоединение(FTPServer);
Для Каждого Файл Из ПолеСписка Цикл
Если Файл.Пометка Тогда
Сервер.Получить(Файл.Значение.ПолноеИмя, "с:\temp" + Файл.Значение.ПолноеИмя);
Файл.Пометка = Ложь;
КонецЕсли;
КонецЦикла;
КонецПроцедуры

// Просмотр файлов на FTP сервере
Процедура Просмотреть(Кнопка)
Сервер = Новый FTPСоединение(FTPServer);
МассивФайлов = Сервер.НайтиФайлы("/","*.*");
Для Каждого Файл Из МассивФайлов Цикл
Если Файл.ЭтоФайл() Тогда
ПолеСписка.Добавить(Файл, Файл.Имя)
КонецЕсли;
КонецЦикла;
КонецПроцедуры


Код 1C v 8.х
 ПапкаКонтрагена = "Kontr";
      
Попытка
ИмяFTPСервера = "*******";
ПортFTPСоединения = "21";
ПользовательFTPСоединения = "****" ;
ПарольFTPСоединения = "*****" ;
ПассивноеFTPСоединение = Ложь;
Соединение = Новый FTPСоединение(ИмяFTPСервера, ПортFTPСоединения,ПользовательFTPСоединения,ПарольFTPСоединения, ,ПассивноеFTPСоединение);
Массив = Соединение.НайтиФайлы("/"+ПапкаКонтрагена+"/", "");
Если Массив.Количество() = 0 Тогда
Соединение.СоздатьКаталог(ПапкаКонтрагена);
КонецЕсли;
Соединение.УстановитьТекущийКаталог(ПапкаКонтрагена);
Соединение.Записать(ИмяФайлаЗаписи, "file.txt");
Исключение
Сообщить("Ошибка записи файла на FTP!!!");
Возврат "";
КонецПопытки;


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.