ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Гуляя по просторам интернета, случайно наткнулся на обработку HTML Редактор (Андрей Михайлов aka MAV):



Далее, пришла в голову интересная идея, сделать красивыми комментарии в документах ( у нас они очень большие и многострочные, в отдельной закладке), с поддержкой копирования информации из WORD и EXCEL, с сохранением всех цветов и стилей. Подредактировав данную обработку, стали доступны следующие функции:

1. Добавление текста

2. Добавление, просмотр и печать

3. Просмотр и печать

Теперь, более подробно:

Вот так выгляди поле комментариев в нашей базе:


1. Нажав на кнопку "Добавить комментарий" срабатывает Процедура ДобавитьКоммент(Элемент)
Код 1C v 8.х
 
      
Процедура ДобавитьКоммент(Элемент)
форм=обработки.HTML.ПолучитьФорму("Форма");
текст = форм.ОткрытьМодально();
если не Пустаястрока(текст) тогда
комментарий="Добавил: "+глтекущийпользователь+" , Добавлено: "+текущаядата()+текст+комментарий;
ЭлементыФормы.ПолеHTMLДокумента.УстановитьТекст(комментарий);
конецесли;
КонецПроцедуры

2. Процедура вызова "Добавление, просмотр и печать"
Код 1C v 8.х
 
      
Процедура ВставитьПланГрафик(Кнопка)
форм=обработки.HTML.ПолучитьФорму("ФормаПросмотра");
форм.текст=ПланГрафик;
текст=форм.ОткрытьМодально();
ПланГрафик=текст+ПланГрафик;
КонецПроцедуры

Откроется форма, вида:


Нажав на "Добавить запись" и вставив Таблицу из Excel:


Нажимаем Добавить и получаем:


3. Просмотр и печать
Код 1C v 8.х
 
      
Процедура ИсторияИзмененийПросмотр(Кнопка)
форм=обработки.HTML.ПолучитьФорму("Просмотр");
форм.текст=ИсторияИзменений;
форм.ОткрытьМодально();
КонецПроцедуры

Откроется форма просмотра реквизита ИсторияИзменений.


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.