ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 
      
// 1. Удаление строк согласно условию
НулевыеСтроки = ТаблицаПослеПодмен.НайтиСтроки(Новый Структура("Сумма",0));
Для каждого СтрокаТаблицы Из НулевыеСтроки Цикл
ТаблицаПослеПодмен.Удалить(СтрокаТаблицы)
КонецЦикла;

// Нужно оставить строки только соответствующие условию,а остальные удалить то:
ПараметрыОтбора = Новый Структура("Цена",15000);
ТЗНов = ТЗ.Скопировать(ПараметрыОтбора);
// в результате в ТЗнов будут только строки из ТЗ, в которых значение поля Цена = 15000

// 2. Удаление определенной строки, например УдаляемаяСтрока = 5;
ТаблицаЗначений.Удалить(УдаляемаяСтрока);

// 3. Удаление первой строки
ТаблицаЗначений.Удалить(0);

// 4. Удаление определенной колонки, например УдаляемаяКолонка = 3;
ТаблицаЗначений.Колонки.Удалить(УдаляемаяКолонка);

// 5. Удалить первую колонку
ТаблицаЗначений.Колонки.Удалить(0);

// 6. Удаление строк перебором, проверяя условие
СтаршийИндексКолонок = ТаблицаЗначений.Колонки.Количество() - 1;
Индекс = ТаблицаЗначений.Количество() - 1;
Пока Индекс > = 0 Цикл
Для Сч = 0 По СтаршийИндексКолонок Цикл
Если ТипЗнч(ТаблицаЗначений[Индекс][Сч]) = Тип("Число") Тогда
ТаблицаЗначений.Удалить(Индекс);
Прервать;
КонецЕсли;
КонецЦикла;
Индекс = Индекс - 1;
КонецЦикла;


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.