Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Реквизит ~ Перебор реквизитов Формы

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 //Перебор Основных Реквизитов формы
      
Для Каждого Рек из ЭтаФорма.Метаданные().Реквизиты Цикл
Сообщить(рек.Имя+" - "+рек.Синоним+" - "+Строка(рек.Тип));
КонецЦикла;
// или так
Для Каждого Рек из Метаданные().Реквизиты Цикл
Сообщить(рек.Имя+" - "+рек.Синоним+" - "+Строка(рек.Тип));
КонецЦикла;

//Реквизиты формы - Надписи, Поля Ввода и т.д
//можно и через ЭтаФорма.ЭлементыФормы
Для Каждого Рек из ЭлементыФормы Цикл
Сообщить(Строка(рек)+" - "+рек.имя);
КонецЦикла;


Перебор реквизитов определенного слоя формы:
Код 1C v 7.x
 Процедура ПриВыбореЗакладки(НомерЗакладки, ЗначениеЗакладки)
      
ТекущаяСтраница = ЗначениеЗакладки;
Форма.ИспользоватьСлой("Кнопки,"+СокрЛП(ТекущаяСтраница), 2);

Если ТекущаяСтраница="зклдПодписание" Тогда
Для Инд = 1 По Метаданные.Справочник("ДоговораНов").Реквизит() Цикл

Реквизит = Метаданные.Справочник("ДоговораНов").Реквизит(Инд);
Если Форма.ПолучитьАтрибут(Реквизит).Видимость() = 1 Тогда
Форма.ПолучитьАтрибут(Реквизит).Доступность(0);
КонецЕсли;

КонецЦикла;
КонецЕсли;

КонецПроцедуры


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.