Простите за всплывающее окно, но мы обязаны предупредить, что наш сайт использует куки-файлы. Это помогает нам быть лучше и полезнее для вас.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Получение остатков регистра запросом, с группировкой по продукту и цене

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 7.x
 ДатаК=РабочаяДата(); 
      
Запрос=СоздатьОбъект("Запрос");
ТекстЗапроса=
"//{{ЗАПРОС(ОстаткиТоваров)
|Период с '01.01.1990' по ДатаК;
|Продукт=Регистр.ПродОст.Продукция;
|Цена=Регистр.ПродОст.Цена;
|Колво=Регистр.ПродОст.Количество;
|Вес=Регистр.ПродОст.Вес;
|Функция КолвоНачОст=НачОст(КолВо);
|Функция КолвоПриход=Приход(КолВо);
|Функция КолвоРасход=Расход(КолВо);
|Функция КолвоКонОст=КонОст(КолВо);
|Функция ВесНачОст=НачОст(Вес);
|Функция ВесПриход=Приход(Вес);
|Функция ВесРасход=Расход(Вес);
|Функция ВесКонОст=КонОст(Вес);
|Группировка Продукт;
|Группировка Цена;
|"//}}ЗАПРОС
;
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Возврат;
КонецЕсли;
Сообщить("1");
//... код вывода
Пока Запрос.Группировка("Продукт") = 1 Цикл
Сообщить("2");
//... код вывода
Пока Запрос.Группировка("Продукт") = 1 Цикл
Сообщить("3");
//... код вывода
КонецЦикла;
КонецЦикла;
Сообщить("4");
//... код вывода
Поделиться в соц. сетях


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.