Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Открыть диалог выбора файла

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 //На форме есть поле (Путь к файлу), для кнопки Выбор (Событие начало выбора) пропишем процедуру выбора файла
      
Процедура ВыборФайла(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
СтандартнаяОбработка=ложь;
Диалог = Новый ДиалогВыбораФайла(РежимДиалогаВыбораФайла.Открытие);
Диалог.Заголовок = "Выберите файл";
Диалог.ПолноеИмяФайла = "";
Фильтр = "EXE (*.exe)|*.exe";
Диалог.Фильтр = Фильтр;
Диалог.МножественныйВыбор = Ложь;
Диалог.Каталог = "F:\";
Если Диалог.Выбрать() Тогда
Элемент.значение = Диалог.ПолноеИмяФайла;
КонецЕсли;
КонецПроцедуры


Код 1C v 7.x
 ИмяВыбрФайла = "";
      
ИмяПути=КаталогИБ()+"ProgFile\";
Если ФС.ВыбратьФайл(0, ИмяВыбрФайла, ИмяПути, "Выберите файл запуска программы", "Все файлы (*.*)!*.*", , ) = 1 Тогда
ПутьЗ=СРЕД((ИмяПути + ИмяВыбрФайла),3,80);
КонецЕсли;


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.