ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Вариант сортировки числового ряда (от малого к великому) методом шейкера. Считается более оптимизированным и быстрым алгоритмом сортировки по сравнению с сортировкой пузырьковым методом. Однако, есть тоже ряд отрицательных сторон (ну куда же без них). Подробно обо всём расскажет google, ну а ниже приведён код функции. Область применения так же достаточно широка.

Код 1C v 8.х
 
      
Функция СортировкаШейкеромРядаЧисел(МассивЭлементов) Экспорт
// Определяем границы массива
НижняяГраница = 0;
ВерхняяГраница = МассивЭлементов.Количество()-1;
// Определяем счётчики циклов, они же - границы неотсортированной части массива
счётчик1 = МассивЭлементов.Количество()-1;
счётчик2 = 0;

// Поехали сортировать массив
Пока НижняяГраница < ВерхняяГраница Цикл
// Проход снизу вверх
Пока счётчик1 >= 0 Цикл
счётчик1 = счётчик1-1;
Если счётчик1 = 0 Тогда
Прервать;
КонецЕсли;
Если МассивЭлементов[счётчик1-1] > МассивЭлементов[счётчик1] Тогда
МладшийЭлемент = МассивЭлементов[счётчик1];
СтаршийЭлемент = МассивЭлементов[счётчик1-1];

МассивЭлементов[счётчик1-1] = МладшийЭлемент;
МассивЭлементов[счётчик1] = СтаршийЭлемент;

счётчик2 = счётчик1;
КонецЕсли;
КонецЦикла;

НижняяГраница = счётчик2+1;

// Проход сверху вниз
счётчик1 = 0;
Пока счётчик1 <= ВерхняяГраница Цикл
счётчик1 = счётчик1+1;
Если счётчик1 = МассивЭлементов.Количество() Тогда
Прервать;
КонецЕсли;
Если МассивЭлементов[счётчик1-1] > МассивЭлементов[счётчик1] Тогда
МладшийЭлемент = МассивЭлементов[счётчик1];
СтаршийЭлемент = МассивЭлементов[счётчик1-1];

МассивЭлементов[счётчик1-1] = МладшийЭлемент;
МассивЭлементов[счётчик1] = СтаршийЭлемент;
счётчик2 = счётчик1;
КонецЕсли;
КонецЦикла;

ВерхняяГраница = счётчик2-1;
КонецЦикла;

Возврат МассивЭлементов;
КонецФункции


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.