ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

В Конфигураторе, нажимаем правой кнопкой на конфигурацию:
Модуль управляемого приложения
Модуль управляемого приложения является аналогом модуля приложения, но используется для управляемого приложения. 1С:Предприятие 8 исполняется в режиме управляемого приложения, если запущен тонкий клиент, Веб-клиент или толстый клиент и при этом установлен режим управляемого приложения либо на всю конфигурацию, либо у конкретного пользователя. В модуле управляемого приложения могут располагаться объявления переменных, процедуры, функции и тело модуля.
Кроме того, в модуле управляемого приложения могут располагаться предопределенные процедуры ПередНачаломРаботыСистемы, ПриНачалеРаботыСистемы, ПередЗавершениемРаботыСистемы, ПриЗавершенииРаботыСистемы, ОбработкаВнешнегоСобытия. Все процедуры и функции отрабатывают на клиенте. В процедурах и функциях модуля управляемого приложения доступны экспортные процедуры и функции общих модулей управляемого клиента, а также общих неглобальных серверных модулей. Процедуры, функции и переменные модуля управляемого приложения доступны из клиентской части модулей форм и команд.
Добавляем нужный нам код, например:
Код 1C v 8.2 УП
 Процедура ПриНачалеРаботыСистемы()
      
Сообщить("Работайте без ошибок :)");
КонецПроцедуры

При закытии программы
Код 1C v 8.2 УП
 Процедура ПриЗавершенииРаботыСистемы()
      
Сообщить("Работайте без ошибок :)");
КонецПроцедуры

Есть еще процедуры Перед:
Код 1C v 8.2 УП
 Процедура ПередНачаломРаботыСистемы()
      
//или
Процедура ПередЗавершениемРаботыСистемы()



В 1С 8.1 Конфигурация - Модуль приложения
Код 1C v 8.х
 Процедура ПриНачалеРаботыСистемы()
      
Сообщить("все");
КонецПроцедуры

Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Пока!");
КонецПроцедуры


Так же есть процедуры Перед:
Код 1C v 8.х
 Процедура ПередНачаломРаботыСистемы()
      
//или
Процедура ПередЗавершениемРаботыСистемы()



В 1С 7.7 Конфигурация - Глобальный модуль
Код 1C v 7.x
 Процедура ПриНачалеРаботыСистемы()
      
Сообщить("все");
КонецПроцедуры

Процедура ПриЗавершенииРаботыСистемы()
Сообщить("Пока!");
КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.