Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 7.x
 
      
// Если передено число - то 1, иначе 0
Функция ЭтоЧисло(Знач ТекСтр)
ТекСтр = СокрЛП(ТекСтр);
ТекСтр = СтрЗаменить(ТекСтр,"0","9");

Если (СтрДлина(Число(ТекСтр)) <> СтрДлина(ТекСтр))
или ((СтрДлина(ТекСтр) = 1) и (Найти("0123456789",ТекСтр) = 0)) Тогда
Возврат 0;
КонецЕсли;

Возврат 1;
КонецФункции


Код 1C v 8.х
 
      
// Если передено число - то истина, иначе ложь
Функция ЯвляетсяЧислом(Значение) Экспорт
Если ТипЗнч(Значение) = Тип("Число") Тогда
Возврат Истина
Иначе
Если ТипЗнч(Значение) = Тип("Строка") Тогда
Если Значение = "" Тогда
Возврат Ложь;
КонецЕсли;
КонецЕсли;

Попытка
Р = Число(Значение);
Исключение
Возврат Ложь;
КонецПопытки;
Возврат Истина;
КонецЕсли;
КонецФункции


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.