ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 Процедура КнопкаDOCНажатие(Элемент)
      

ИмяФайла = ПолучитьИмяВременногоФайла("doc");
Doc = ХранилищеФайла.Получить();

Если Doc <> Неопределено Тогда

Doc.Записать(ИмяФайла)
Word = Новый COMОбъект("Word.Application");
Word.Documents.Open(ИмяФайла);
Word.Visible = Истина;

ДобавитьОбработчик Word.DocumentBeforeClose, ПередЗакрытиемДокументаWord;
ДобавитьОбработчик Word.Quit, ВыходИзWord;

КонецЕсли;

КонецПроцедуры

//Процедуры назначаемые обработчиками
Процедура ПередЗакрытиемДокументаWord(Документ, Отмена)
Документ.Save();
КонецПроцедуры

Процедура ВыходИзWord()
ШаблонДоговора = Новый ХранилищеЗначения(Новый ДвоичныеДанные(ИмяФайла));
КонецПроцедуры



Тема обсуждения

Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.