Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 
      
РегистрыНакопления.ЗаказыМагазинов.УстановитьИспользованиеИтогов(Ложь);
Запрос=Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ РАЗЛИЧНЫЕ
| Регистр.Регистратор
|ИЗ
| РегистрНакопления.ЗаказыМагазинов КАК Регистр
|ГДЕ
| Регистр.Регистратор.Дата<&КонПериода";
Запрос.УстановитьПараметр("КонПериода",КонПериода);
РезультатЗапроса = Запрос.Выполнить();
Выборка = РезультатЗапроса.Выбрать();
Кол=0;
БылиОшибки=Ложь;
Пока Выборка.Следующий() цикл
ОбработкаПрерыванийПользователя();
Набор = РегистрыНакопления.ЗаказыМагазинов.СоздатьНаборЗаписей();
Набор.Отбор.Регистратор.Значение = Выборка.Регистратор;
Попытка
Набор.Записать();
Исключение
БылиОшибки=Истина;
КонецПопытки;
Кол=Кол+1;
ЕСЛИ Кол%100=0 Тогда
Сообщить("Отработано "+Кол+" документов из "+Выборка.Количество());
КонецЕсли;
КонецЦикла;
Если БылиОшибки Тогда
Предупреждение("Обработка завершена. Регистр очищен не до конца!!!");
КонецЕсли;
РегистрыНакопления.ЗаказыМагазинов.УстановитьИспользованиеИтогов(Истина);


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.