ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Генератор случайных чисел инициализируется начальным числом из параметра:

Код 1C v 8.х
 НачальноеЧисло = 167;
      
ГСЧ = Новый ГенераторСлучайныхЧисел(НачальноеЧисло);
СлучайноеЧисло = ГСЧ.СлучайноеЧисло(0, 1000);


Последовательность случайных чисел для одного и того же начального числа будет одинакова.
При создании генератора случайных чисел можно не передавать ему начальное число. В этом случае он инициализируется временем работы операционной системы с момента старта.
Код 1C v 8.х
 ГСЧ = Новый ГенераторСлучайныхЧисел();
      
СлучайноеЧисло = ГСЧ.СлучайноеЧисло(0, 1000);


Еще примеры самодельных функций:
Код 1C v 8.х
 Функция Рандом() Экспорт
      
UID=Новый УникальныйИдентификатор();
UID = СтрЗаменить(UID,"-","");
Значение = "";
Для Н=1 По СтрДлина(UID) Цикл
Симв = Сред(UID,Н,1);
Значение = Значение+Прав(КодСимвола(Симв),1);
КонецЦикла;
Возврат Число("0."+Значение);
КонецФункции

Код 1C v 8.х
 Функция Ранд(Парам=0)
      
Если Парам<>0 Тогда
Случай=Парам;
КонецЕсли;
Если Число(Случай)=0 Тогда
Случай=Число(СтрЗаменить(""+ТекущееВремя(),":",""));
Случай=(16807*Случай)%2147483647;
КонецЕсли;
Случай=(16807*Случай)%2147483647;
Случай=макс(Случай,-Случай);
Возврат(Случай/2147483647);
КонецФункции



Для 7.7 можно использовать генератор случайностей
Код 1C v 7.x
 ремоте=СоздатьОбъект("rcbdyctl.setting");
      
Сообщить(ремоте.CreatePassword);


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.