ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Оптимальным решением является установка. После установки в системе появляется виртуальный принтер, с помощью которого можно "печатать" в файл pdf из любого приложения. Программа бесплатная, работает в терминале и имеет поддержку русского языка.<br>После установки, можно печатать напрямую используя код:<br><fieldset><legend style="color: #001a34;">Код 1C v 8.х</legend><pre><code class="1c8"> <br>//Таб - ТабличныйДокумент<br>//ИмяФайла – путь для сохранения файла PDF  (например «D:\Torg12.pdf»)<br>Процедура СоздатьФайлПДФ(Таб, ИмяФайла)<br><br>Попытка<br>ПДФПринтер = Новый ComObject(«Bullzip.PDFPrinterSettings»);<br>ПДФПринтер.SetValue(«output», ИмяФайла);<br>ПДФПринтер.SetValue(«ShowSaveAS», «never»);<br>ПДФПринтер.SetValue(«ShowProgress», «no»);<br>ПДФПринтер.SetValue(«ShowProgressFinished», «no»);<br>ПДФПринтер.SetValue(«ShowSettings», «never»);<br>ПДФПринтер.SetValue(«ShowPDF», «no»);<br>ПДФПринтер.SetValue(«ConfirmOverwrite»,»no»);<br>ПДФПринтер.WriteSettings();<br>Таб.Автомасштаб = Истина;<br>Таб.ИмяПринтера = «Bullzip PDF Printer»;Таб.Напечатать(Истина);<br>PDFФайл = Новый Файл(ИмяФайла);<br><br>Пока НЕ PDFФайл.Существует() Цикл<br>ОбработкаПрерыванияПользователя();<br>КонецЦикла;<br><br>Исключение<br><br>Сообщить(ОписаниеОшибки());<br>Сообщить(«Скорее всего необходимо установить или переустановить «»Bullzip PDF Printer»);<br>КонецПопытки;<br>//устанавливаем принтер по умолчанию<br>Таб.ИмяПринтера = ПолучитьПринтерПоУмолчанию();<br>КонецПроцедуры   </code></pre></fieldset><br>Здесь функция<b> ПолучитьПринтерПоУмолчанию()</b> нужна для того чтобы вернуть печатной форме принтер по умолчанию, т.к. если напечатать без предварительного просмотра то печать пойдет на виртуальный PDF принтер BullzipPDFPrinter.<br><fieldset><legend style="color: #001a34;">Код 1C v 8.х</legend><pre><code class="1c8"> //получаем принтер по умолчанию<br>Функция ПолучитьПринтерПоУмолчанию()<br><br>Скрипт = Новый ComObject(«MSScriptControl.ScriptControl»);<br>Скрипт.Language = «vbscript»;<br>Скрипт.AddCode(»<br>|Function GetDefaultPrinter()<br>|GetDefaultPrinter=vbNullString<br>|Set objWMIService=GetObject(«»winmgmts:»" _<br>|& «»{impersonationLevel=impersonate}!\\.\root\cimv2&#8243;»)<br>|Set colInstalledPrinters=objWMIService.ExecQuery _<br>|(«»S_elect * from Win32_Printer»")<br>|For Each objPrinter in colInstalledPrinters<br>|If objPrinter.Attributes and 4 Then<br>|GetDefaultPrinter=objPrinter.Name<br>|Exit For<br>|End If<br>|Next<br>|End Function»);<br>Возврат СокрЛП(Скрипт.run(«GetDefaultPrinter»));<br>КонецФункции   </code></pre></fieldset><br><hr/><br>


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.