ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Методы доступны только при проведении документа в предопределенной процедуре ОбработкаПроведения.
Метод Движение - Выполнить запись движения в оборотный регистр по параметрам.
Код 1C v 7.x
 
      
Регистр.Товары.Движение (ПоступившийТовар, ТекСклад, КолвоПоНакладной, СуммаПоНакладной)

Код 1C v 7.x
 
      
Процедура ОбработкаПроведения();
ВыбратьСтроки();
Пока ПолучитьСтроку() > 0 Цикл
Регистр.ОборотыТоваров.Движение(Товар, Склад, ОборотТовара);
КонецЦикла;
КонецПроцедуры


Метод ДвижениеВыполнить - Выполнить запись движения в оборотный регистр по атрибутам.
Код 1C v 7.x
 Процедура ОбработкаПроведения();
      
Регистр.ТовЗап.Склад = Склад;
ВыбратьСтроки();
Пока (ПолучитьСтроку() > 0) Цикл
Регистр.ТовЗап.Товар = Товар;
Регистр.ТовЗап.Оборот = Оборот;
Регистр.ТовЗап.ДвижениеВыполнить();
КонецЦикла;
КонецПроцедуры;


Примечание: Если сумма или количество в движении будет отрицательным, то это движение будет расходом, иначе приходом.


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.