Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проконсультироваться
со специалистом 1С

Консультироваться

Методы ДвижениеПриход и ДвижениеРасход, доступны только при проведении документа в предопределенной процедуре ОбработкаПроведения.

Код 1C v 7.x
 ВыбратьСтроки(); //Переберем строки документа
      
Пока ПолучитьСтроку() > 0 Цикл
Регистр.ТовЗап.ПривязыватьСтроку(НомерСтроки); //Записать НомерСтроки документа в движении регистра.
Регистр.ТовЗап.ДвижениеПриход(Склад, Товар, Количество, Стоимость);
КонецЦикла;
//или
Процедура ОбработкаПроведения()
строк = КоличествоСтрок();
ВыбратьСтроки(); //Переберем строки документа
Пока ПолучитьСтроку()=1 Цикл
Сообщить("Склад=" + Склад + " Получатель=" + Получатель+ " Товар="+Товар+" кол-во="+Количество+" сумма="+Количество*Цена);
Регистр.Остатки_товаров.ДвижениеРасход(Товар,Склад,Получатель,Количество,Количество*Цена);
КонецЦикла;
КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.