ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Методы ДвижениеПриход и ДвижениеРасход, доступны только при проведении документа в предопределенной процедуре ОбработкаПроведения.

Код 1C v 7.x
 ВыбратьСтроки(); //Переберем строки документа
      
Пока ПолучитьСтроку() > 0 Цикл
Регистр.ТовЗап.ПривязыватьСтроку(НомерСтроки); //Записать НомерСтроки документа в движении регистра.
Регистр.ТовЗап.ДвижениеПриход(Склад, Товар, Количество, Стоимость);
КонецЦикла;
//или
Процедура ОбработкаПроведения()
строк = КоличествоСтрок();
ВыбратьСтроки(); //Переберем строки документа
Пока ПолучитьСтроку()=1 Цикл
Сообщить("Склад=" + Склад + " Получатель=" + Получатель+ " Товар="+Товар+" кол-во="+Количество+" сумма="+Количество*Цена);
Регистр.Остатки_товаров.ДвижениеРасход(Товар,Склад,Получатель,Количество,Количество*Цена);
КонецЦикла;
КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.