ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 Процедура ВыгрузкаПроводок(Кнопка)
      
Если Не ЗначениеЗаполнено(Документ) Тогда
Сообщить("Заполните поле Документ!");
Иначе
Движ = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
Движ.Отбор.Регистратор.Установить(Документ);
Движ.Прочитать();
ТЗ = Движ.Выгрузить();
ПараметрОтбора = Новый Структура("СчетДт",Счет);
ТЗИтог = ТЗ.Скопировать(ПараметрОтбора);
Если ЗначениеВФайл("D:\OUT.TXT",ТЗ) Тогда
Сообщить("Создан файл ""D:\OUT.TXT""");
КонецЕсли;
КонецЕсли;
КонецПроцедуры

Процедура ЗагрузитьПроводки(Кнопка)
ТЗЗагрузка = ЗначениеИзФайла("D:\OUT.TXT");
Движ = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
Движ.Отбор.Регистратор.Установить(Документ);
Движ.Прочитать();
ТЗ = Движ.Выгрузить();
Для Каждого Эл Из ТЗЗагрузка Цикл
ПараметрОтбора = Новый Структура("СчетДт,СубконтоДт1",Эл.СчетДт,Эл.СубконтоДт1);
Массив = ТЗ.НайтиСтроки(ПараметрОтбора);
Если Массив.Количество()>0 Тогда
Сообщить("Запись есть - Пропускаем!");
Продолжить;
Иначе
Сообщить("Записи нет - Добавляем!");
НоваяСтрока = ТЗ.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока,Эл);
КонецЕсли;
КонецЦикла;
Движ.Загрузить(ТЗ);
Движ.Записать();
Сообщить("Проводки для данного документа созданы успешно!");
КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.