ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 // ПутьКФайлу – Строка – путь к файлу.
      
//
// Возвращаемое значение:
// Строка – каталог файла
//
Функция ПолучитьКаталогФайла(Знач ПутьКФайлу) Экспорт

ПозицияСимвола = СтрДлина(ПутьКФайлу);
Пока ПозицияСимвола >= 1 Цикл
Если Сред(ПутьКФайлу, ПозицияСимвола, 1) = "\" Тогда
Возврат ПозицияСимвола;
КонецЕсли;
ПозицияСимвола = ПозицияСимвола - 1;
КонецЦикла;

Если ПозицияСимвола > 1 Тогда
Возврат Сред(ПутьКФайлу, 1, ПозицияСимвола - 1);
Иначе
Возврат "";
КонецЕсли;

КонецФункции


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.