Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Возвратить каталог файла - часть пути без имени файла

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 // ПутьКФайлу – Строка – путь к файлу.
      
//
// Возвращаемое значение:
// Строка – каталог файла
//
Функция ПолучитьКаталогФайла(Знач ПутьКФайлу) Экспорт

ПозицияСимвола = СтрДлина(ПутьКФайлу);
Пока ПозицияСимвола >= 1 Цикл
Если Сред(ПутьКФайлу, ПозицияСимвола, 1) = "\" Тогда
Возврат ПозицияСимвола;
КонецЕсли;
ПозицияСимвола = ПозицияСимвола - 1;
КонецЦикла;

Если ПозицияСимвола > 1 Тогда
Возврат Сред(ПутьКФайлу, 1, ПозицияСимвола - 1);
Иначе
Возврат "";
КонецЕсли;

КонецФункции


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.