Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Удалить строки из табличной части справочника

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.2 УП
 &НаКлиенте
      
Процедура ОбработатьВыполнить()
Объект.Обработан=Истина;
БылоСтрок= Объект.Данные.Количество();
Для Счетчик =1 по Объект.Данные.Количество() Цикл
НомерСтроки= БылоСтрок-Счетчик;
лСтр = Объект.Данные[НомерСтроки];
Если лСтр.Группа = Объект.ВозрастнаяГруппа Тогда
// оставляем
Иначе
Объект.Данные.Удалить(НомерСтроки);
КонецЕсли;
КонецЦикла;
КонецПроцедуры


Код 1C v 8.х
 ЭлементСправочника = Справочники.Контрагенты.НайтиПоКоду("Ю0006"); 
      
ОбъектСправочника = ЭлементСправочника.ПолучитьОбъект();
ОбъектСправочника.ВидыДеятельности.Очистить();
ОбъектСправочника.Записать();

ОбъектСправочника = ВыбранныйЭлемент.ПолучитьОбъект();

// Создать структуру для отбора удаляемых строк.
СтруктураОтбора = Новый Структура("ВидДеятельности", ВыбранныйВидДеятельности);

// Получить массив удаляемых строк.
ПодходящиеСтроки = ОбъектСправочника.ВидыДеятельности.НайтиСтроки(СтруктураОтбора);

// Удалить строки.
Для Каждого ОчереднаяСтрока Из ПодходящиеСтроки Цикл
ОбъектСправочника.ВидыДеятельности.Удалить(ОчереднаяСтрока);
КонецЦикла;
ОбъектСправочника.Записать();


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.