Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Удаление пустых колонок в таблице значений

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 Процедура УдалитьПустыеКолонкиТЗ(ТЗ)
      
МассивВозможноПустыхКолонок=Новый Массив;
Для Каждого ТекКолонка Из ТЗ.Колонки Цикл
МассивВозможноПустыхКолонок.Добавить(ТекКолонка.Имя);
КонецЦикла;
Для Каждого СтрТЗ из ТЗ Цикл
КолВоВозможноПустыхКолонок=МассивВозможноПустыхКолонок.Количество();
Для К=1 по КолВоВозможноПустыхКолонок Цикл
Если ЗначениеЗаполнено(СтрТЗ[МассивВозможноПустыхКолонок[КолВоВозможноПустыхКолонок-К]]) Тогда
МассивВозможноПустыхКолонок.Удалить(КолВоВозможноПустыхКолонок-К);
КонецЕсли;
КонецЦикла;
КонецЦикла;
КолВоВозможноПустыхКолонок=МассивВозможноПустыхКолонок.Количество();
Для К=0 по КолВоВозможноПустыхКолонок-1 Цикл
ТЗ.Колонки.Удалить(МассивВозможноПустыхКолонок[К]);
КонецЦикла;
КонецПроцедуры


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.