ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

В стандартных конфигурациях есть такая проверка, например :
В ЗУПе у пользователя должна быть доступна роль "Пользователь" или "ПолныеПрава"
В Бухгалтерии у пользователя должна быть доступна роль "Бухгалтер" или "ПолныеПрава"

А проверяет это кусок кода вида:
Код 1C v 8.х
 
      
// Функция проверяет установлены ли у пользователя роли,
// с которыми можно запускать конфигурацию
Функция ЕстьДоступныеПраваДляЗапускаКонфигурации() Экспорт

Возврат РольДоступна("ПолныеПрава")
ИЛИ РольДоступна("Пользователь")
ИЛИ ЕстьРолиБезОграниченияПравДоступаНаУровнеЗаписей();

КонецФункции

//.....
// а ниже
Если НЕ ЕстьДоступныеПраваДляЗапускаКонфигурации() Тогда
Отказ = Истина;
#Если Клиент Тогда
Предупреждение("У текущего пользователя нет ролей, допускающих запуск информационной базы!", 10, "Недостаточно прав доступа");
#КонецЕсли
КонецЕсли;


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.