ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Для включения всех видов расчетов в произвольный список значений без использования перебора групп видов расчетов можно использовать функцию Шаблон().

Код 1C v 7.x
 //Функция присвоения значения
      
Функция ПолучениеВР(ВР,Объект)
ВР = Объект;
Возврат "";
КонецФункции

//Ниже приведен цикл перебора видов расчетов
сзВидыРасчетов = СоздатьОбъект("СписокЗначений");
Для А = 1 По Метаданные.ВидРасчета() Цикл
текВР = Метаданные.ВидРасчета(А);
Шаблон("[ПолучениеВР(ВР,"+текВР.ПолныйИдентификатор()+")]");
Если ПустаяСтрока(текВР.Синоним) = 1 Тогда
стрВР = текВР.Идентификатор;
Иначе
стрВР = текВР.Синоним;
КонецЕсли;
сзВидыРасчетов.ДобавитьЗначение(ВР,стрВР);
КонецЦикла;


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.