ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

<fieldset><legend style="color: #001a34;">Код 1C v 8.2 УП</legend><pre><code class="1c8"> &НаКлиенте<br>Процедура ПоКнопкеНовыйКонтрагент(Команда)<br>       // Вставить содержимое обработчика.<br>        Перем НовыйКонтрагент;<br><br>        НовыйКонтрагент = Новый Структура("Наименование, ПолноеНаименование, ИНН");<br>        НовыйКонтрагент.Наименование = "РиК ООО";<br>        НовыйКонтрагент.ПолноеНаименование = "ООО Рога и копыта"; <br>        НовыйКонтрагент.ИНН =  "123456789012";<br><br> <br>        Если СоздатьНовогоКонтрагента(НовыйКонтрагент) = 0 Тогда<br>                Сообщить("Не удалось создать нового контрагента");<br>        КонецЕсли;<br><br>КонецПроцедуры<br> <br><br>&НаСервере<br>Функция СоздатьНовогоКонтрагента(СтруктураСправочника)<br><br>        Перем НовыйКонтрагент,СпрПользователи;<br><br>        СпрКонтрагенты = Справочники.Контрагенты;<br>        НовыйКонтрагент = СпрКонтрагенты.СоздатьЭлемент();<br>        НовыйКонтрагент.Наименование = СтруктураСправочника.Наименование;<br>        НовыйКонтрагент.ПолноеНаименование = СтруктураСправочника.ПолноеНаименование; <br>        НовыйКонтрагент.ИНН = СтруктураСправочника.ИНН;<br>        Попытка<br>                НовыйКонтрагент.Записать();<br>                Возврат 1;<br>        Исключение<br>                Возврат 0;<br>        КонецПопытки;<br><br>КонецФункции    </code></pre></fieldset><br><hr/><br><fieldset><legend style="color: #001a34;">Код 1C v 8.х</legend><pre><code class="1c8"> //Пример 1<br>НовыйЭлемент = Справочники.Контрагенты.СоздатьЭлемент(); <br>НовыйЭлемент.Наименование = "ООО Березка"; <br>// Установить другие реквизиты.  <br>НовыйЭлемент.Записать(); <br><br>НовыйЭлемент = Справочники.Банки.СоздатьЭлемент(); <br>// Получить ссылку на группу, в которой будет находиться новый элемент. <br>Родитель = Справочники.Банки.НайтиПоКоду("000000001"); <br>НовыйЭлемент.Наименование = "ВТБ"; <br>НовыйЭлемент.Код = "000000011"; <br>НовыйЭлемент.Родитель = Родитель; <br><br>// Установить другие реквизиты.  <br>НовыйЭлемент.Записать(); <br><br>//Пример 2<br>СпрСотр = Справочники.Сотрудники;<br>//или так:<br>//СпрСотр = Справочники["Сотрудники"]<br>НовЭл = СпрСотр.СоздатьЭлемент();<br>НовЭл.Наименование = "Иванов Иван Иванович";<br>НовЭл.Оклад = 100;<br>НовЭл.Записать();<br>   </code></pre></fieldset><br><br><fieldset><legend style="color: #001a34;">Код 1C v 7.x</legend><pre><code class="1c7">  //Пример 1<br>//создаваться будет прямо в корне справочника<br>спр = создатьОбъект("Справочник.Контрагенты");<br>спр.Новый();<br>спр.Наименование = "ООО Березка";<br>спр.УстановитьНовыйКод();<br>// итак далее<br>//спр.Реквизит1="......"<br>//спр.Реквизит2="......"<br>спр.Записать(); <br><br>//Пример 2<br>СпрСотр = СоздатьОбъект("Справочник.Сотрудники");     <br>СпрСотр.Новый();<br>СпрСотр.Наименование = "Иванов Иван Иванович";<br>СпрСотр.Оклад = 100;<br>СпрСотр.Записать();</code></pre></fieldset>


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.