Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Реквизит ~ Функция проверяет заполненность реквизитов объекта

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 //СписокРеквизитов - список значений. Элемент списка значений - имена реквизитов для проверки через запятую. 
      
//Если представление заполнено - считается, что передаются реквизиты табличной части. Пример:
СписокРеквизитовДляПроверки=Новый СписокЗначений;
СписокРеквизитовДляПроверки.Добавить("Контрагент,МестоХранения,ВидОперации");
СписокРеквизитовДляПроверки.Добавить("Номенклатура,Единица,Цена,Количество","ПолнаяТаблица");
СписокРеквизитовДляПроверки.Добавить("ВидОтклонений,Номенклатура,Единица,Серия,Цена,Количество","ТаблицаОтклонений");

Если Не глРеквизитыОбъектаЗаполнены(Источник,СписокРеквизитовДляПроверки) Тогда
Отказ=Истина;
Возврат;
КонецЕсли;

Функция глРеквизитыОбъектаЗаполнены(Объект,СписокРеквизитов) Экспорт
МетаданныеОбъекта=Объект.Метаданные();
МетаданныеТабличныеЧасти=МетаданныеОбъекта.ТабличныеЧасти;

РеквизитыЗаполнены=Истина;

СтрокаДляВыполнения="";

Для каждого НаборРеквизитов Из СписокРеквизитов Цикл
НаименованиеТаблицы=НаборРеквизитов.Представление;
РеквизитыДляПроверки=СтрЗаменить(НаборРеквизитов.Значение,",",Символы.ПС);

ДлинаСпискаРеквизитов=СтрЧислоСтрок(РеквизитыДляПроверки);

Если НаименованиеТаблицы<>"" Тогда
МетаданныеТаблица=МетаданныеТабличныеЧасти[НаименованиеТаблицы];
МетаданныеРевизитыТаблицы=МетаданныеТаблица.Реквизиты;

ТаблицаОбъекта=Объект[НаименованиеТаблицы];

Для СчетчикСтрокРевизитов=1 По ДлинаСпискаРеквизитов Цикл
ИдентРеквизита=СтрПолучитьСтроку(РеквизитыДляПроверки,СчетчикСтрокРевизитов);

МетаданныеРеквизит=МетаданныеРевизитыТаблицы[ИдентРеквизита];
ОписаниеТиповРеквизита=МетаданныеРеквизит.Тип;
ТипыЗначенийРеквизита=ОписаниеТиповРеквизита.Типы();

СтрокаПоиска=ТаблицаОбъекта.Найти(глПолучитьПустоеЗначениеТипа(ТипыЗначенийРеквизита[0]),ИдентРеквизита);
Если СтрокаПоиска=Неопределено Тогда
Продолжить;
КонецЕсли;

Возврат глВозвратЛожьССообщением("Не заполнен реквизит """+МетаданныеРеквизит.Синоним+""" Табличная часть строка "+СтрокаПоиска.НомерСтроки);
КонецЦикла;
Иначе
Для СчетчикСтрокРевизитов=1 По ДлинаСпискаРеквизитов Цикл
ИдентРеквизита=СтрПолучитьСтроку(РеквизитыДляПроверки,СчетчикСтрокРевизитов);

Если Не ЗначениеЗаполнено(Объект[ИдентРеквизита]) Тогда
МетаданныеРевизитыШапки=МетаданныеОбъекта.Реквизиты;
Попытка
Возврат глВозвратЛожьССообщением("Не заполнен реквизит """+МетаданныеРевизитыШапки[ИдентРеквизита].Синоним+"""");
Исключение
Возврат глВозвратЛожьССообщением("Не заполнен реквизит """+ИдентРеквизита+"""");
КонецПопытки;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецЦикла;

Возврат Истина;
КонецФункции



Код 1C v 8.х
 // Ярослав Волохов aka YVolohov
      
// Функция проверяет заполнение шапки или табличной части справочника, документа или плана, бизнес-процесса, задачи
// Параметры:
// пИмяТаблицы (строка) - имя табличной части объекта, если не указано то будет проверятся шапка объекта
// пИменаПолей (массив строк) - имена проверяемых реквизитов объекта
// пВыводитьСообщения - если это свойство установлено в "Истина" то будут выводится сообщения в табло о
// незаполненных реквизитах таблицы, если не установлено - то не будут
// пСсылка (ссылка) - ссылка на элемент справочника или плана, документ, по которому будет произведена проверка
// Возвращаемое значение:
// Истина - если все реквизиты найдены и заполнены
// Ложь - если хоть один реквизит не заполнен, табличная часть не найдена
// или хоть один реквизит не найден

Функция ПроверитьЗаполнениеТаблицыОбъекта(пИмяТаблицы = Неопределено,
пИменаПолей, пВыводитьСообщения = Истина, пСсылка) Экспорт

МассивСообщений = Новый Массив;
ЗначениеВозврата = Истина;
МетаданныеОбъекта = пСсылка.Метаданные();

Если НЕ(пИмяТаблицы = Неопределено) Тогда
МетаданныеТаблицы = МетаданныеОбъекта.ТабличныеЧасти.Найти(пИмяТаблицы);
Иначе
МетаданныеТаблицы = МетаданныеОбъекта;
КонецЕсли;

// Проверка существования табличной части
Если НЕ(МетаданныеТаблицы = Неопределено) Тогда

МассивМетаданныхРеквизитов = Новый Массив;
МетаданныеРеквизитов = МетаданныеТаблицы.Реквизиты;

// Проверка существования полей
Для Каждого ИмяПоля Из пИменаПолей Цикл

МетаданныеРеквизита = МетаданныеРеквизитов.Найти(ИмяПоля);

Если НЕ(МетаданныеРеквизита = Неопределено) Тогда
МассивМетаданныхРеквизитов.Добавить(МетаданныеРеквизита);
Иначе

Если пИмяТаблицы = Неопределено Тогда
МассивСообщений.Добавить("Реквизит шапки с именем '" + ИмяПоля + "' не найден !!!");
Иначе
МассивСообщений.Добавить("Реквизит табличной части '" + пИмяТаблицы + "' с именем '" +
ИмяПоля + "' не найден !!!");
КонецЕсли;

ЗначениеВозврата = Ложь;
КонецЕсли;

КонецЦикла;

// Проверка заполнения полей
КоличествоСтрокТаблицы = ?(НЕ(пИмяТаблицы = Неопределено), пСсылка[пИмяТаблицы].Количество(), 1);
КоличествоСтрокТаблицы = ?(МассивМетаданныхРеквизитов.Количество() > 0, КоличествоСтрокТаблицы, 0);

// Обход строк таблицы
Для НомерСтрокиТаблицы = 1 По КоличествоСтрокТаблицы Цикл

СтрокаТаблицы = ?(НЕ(пИмяТаблицы = Неопределено),
пСсылка[пИмяТаблицы].Получить(НомерСтрокиТаблицы - 1), пСсылка);

// Обход списка проверяемых реквизитов
Для Каждого ЭлементМетаданныхРеквизитов Из МассивМетаданныхРеквизитов Цикл

// Получение значения ячейки и проверка ее заполнения
ЗначениеЯчейкиТЧ = СтрокаТаблицы[ЭлементМетаданныхРеквизитов.Имя];
ЯчейкаПустая = НЕ(ЗначениеЗаполнено(ЗначениеЯчейкиТЧ));

// Если значение пустое, добавляем сообщение в массив сообщений
Если ЯчейкаПустая Тогда

Если пИмяТаблицы = Неопределено Тогда
МассивСообщений.Добавить("Реквизит шапки с именем '" + ЭлементМетаданныхРеквизитов.Имя + "' не заполнен !!!");
Иначе
МассивСообщений.Добавить("В строке № " + НомерСтрокиТаблицы + " табличной части '" +
пИмяТаблицы + "' не заполнен реквизит с именем '" + ЭлементМетаданныхРеквизитов.Имя + "' !!!");
КонецЕсли;

ЗначениеВозврата = Ложь;

КонецЕсли;

КонецЦикла;

КонецЦикла;

Иначе
МассивСообщений.Добавить("Табличная часть с именем '" + пИмяТаблицы + "' не найдена !!!");
ЗначениеВозврата = Ложь;
КонецЕсли;

// Здесь выводим все сообщения
Если пВыводитьСообщения Тогда

Для Каждого ТекстСообщения Из МассивСообщений Цикл
Сообщить(ТекстСообщения, СтатусСообщения.Важное);
КонецЦикла;

КонецЕсли;

Возврат ЗначениеВозврата;

КонецФункции


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.