ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 //Cохранение значений реквизитов формы в файл - таблицу значений тоже сохраняет.
      
Код следующий:
Процедура СохранитьЗначенияФормы()
СтруктураЭлементов = Новый Структура;
Для Каждого ЭлементФормы Из ЭлементыФормы Цикл
Если ЗначениеЗаполнено(ЭлементФормы.Данные) Тогда
ЗнВСтр = ЗначениеВСтрокуВнутр(ЭлементФормы.Значение);
СтруктураЭлементов.Вставить(ЭлементФормы.Имя, ЗнВСтр);
КонецЕсли;
КонецЦикла;
ЗначениеВФайл("C:\temp\rekv.ini", СтруктураЭлементов);
КонецПроцедуры

Процедура ВосстановитьЗначенияФормы()
СтруктураЭлементов = Новый Структура;
СтруктураЭлементов = ЗначениеИзФайла("C:\temp\rekv.ini");
Для Каждого ЭлементФормы Из ЭлементыФормы Цикл
Попытка
ЭлементФормы.Значение = ЗначениеИзСтрокиВнутр(СтруктураЭлементов[ЭлементФормы.Имя])
Исключение
КонецПопытки;
КонецЦикла;
КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.