Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проверка контрагентов на задвоение по ИНН при вводе

Проконсультироваться
со специалистом 1С

Консультироваться

В 7.7 Откройте Справочник Контрагенты - Форма Элемента, двойным щелчком по полю ИНН, на закладке Дополнительно в поле формула введите ПроверкаИНН()
И в Модуль добавьте процедуру ПроверкаИНН()
Код 1C v 7.x
 Процедура ПроверкаИНН() 
      
СпрКонтрагенты = СоздатьОбъект("Справочник.Контрагенты");
Если СпрКонтрагенты.НайтиПоРеквизиту("ИНН",ИНН,1) = 1 Тогда
Предупреждение("Найден контрагент с таким же ИНН :"+РазделительСтрок+Строка(СпрКонтрагенты.Код)+" - "+Строка(СпрКонтрагенты));
КонецЕсли;
КонецПроцедуры


В 8- ой версии, откройте Справочник Контрагенты - Форму Элемента, двойным щелчком по полю ИНН, в событиях ПриИзменении введите ПроверкаИНН()
И в Модуль добавьте процедуру ПроверкаИНН()
Код 1C v 8.х
 Процедура ПроверкаИНН() 
      
СпрКонтрагенты = Справочники.Контрагенты;
Если СпрКонтрагенты.НайтиПоРеквизиту("ИНН",ИНН) Тогда
Предупреждение("Найден контрагент с таким же ИНН :"+РазделительСтрок+Строка(СпрКонтрагенты.Код)+" - "+Строка(СпрКонтрагенты));
КонецЕсли;
КонецПроцедуры


Теперь при вводе ИНН происходит проверка, если Контрагент с таким ИНН уже есть в базе, то выдается Предупреждение!

Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.