Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проведение выбранных документов, отмена проведения выбранных документов

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 Процедура Провести(Кнопка)
      
ВыборкаДокументов = Документы.НДФЛиЕСНДоходыИНалоги.Выбрать();
Пока ВыборкаДокументов.Следующий() Цикл
// Проводим только те документы у которых в комментарии есть "НДФЛ Доходы и удержания"
Если Найти(ВыборкаДокументов.Комментарий, "НДФЛ Доходы и удержания") > 0 Тогда
ТекДок=ВыборкаДокументов.ПолучитьОбъект();
Попытка
ТекДок.Записать(РежимЗаписиДокумента.Проведение);
Сообщить("Проведен документ :" + Строка(ТекДок));
Исключение
Сообщить("Невозможно провести документ("+Строка(ТекДок)+"), т.к.:");
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
КонецЦикла
КонецПроцедуры

Процедура ОтменитьПроведение(Кнопка)
ВыборкаДокументов = Документы.НДФЛиЕСНДоходыИНалоги.Выбрать();
Пока ВыборкаДокументов.Следующий() Цикл
Если Найти(ВыборкаДокументов.Комментарий, "НДФЛ Доходы и удержания") > 0 Тогда
ТекДок=ВыборкаДокументов.ПолучитьОбъект();
Попытка
ТекДок.Записать(РежимЗаписиДокумента.ОтменаПроведения);
Сообщить("Отмена проведения документ :" + Строка(ТекДок));
Исключение
Сообщить("Невозможно отменить проведение("+Строка(ТекДок)+"), т.к.:");
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
КонецЦикла
КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.