Личный кабинет Консультация он-лайн
С заботой
о клиенте!
+7 (495) 223-32-11
Работаем по всей России
8 (800) 775-90-01
Бесплатно, круглосуточно
Заказать звонок

Проведение выбранных документов, отмена проведения выбранных документов

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 Процедура Провести(Кнопка)
      
ВыборкаДокументов = Документы.НДФЛиЕСНДоходыИНалоги.Выбрать();
Пока ВыборкаДокументов.Следующий() Цикл
// Проводим только те документы у которых в комментарии есть "НДФЛ Доходы и удержания"
Если Найти(ВыборкаДокументов.Комментарий, "НДФЛ Доходы и удержания") > 0 Тогда
ТекДок=ВыборкаДокументов.ПолучитьОбъект();
Попытка
ТекДок.Записать(РежимЗаписиДокумента.Проведение);
Сообщить("Проведен документ :" + Строка(ТекДок));
Исключение
Сообщить("Невозможно провести документ("+Строка(ТекДок)+"), т.к.:");
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
КонецЦикла
КонецПроцедуры

Процедура ОтменитьПроведение(Кнопка)
ВыборкаДокументов = Документы.НДФЛиЕСНДоходыИНалоги.Выбрать();
Пока ВыборкаДокументов.Следующий() Цикл
Если Найти(ВыборкаДокументов.Комментарий, "НДФЛ Доходы и удержания") > 0 Тогда
ТекДок=ВыборкаДокументов.ПолучитьОбъект();
Попытка
ТекДок.Записать(РежимЗаписиДокумента.ОтменаПроведения);
Сообщить("Отмена проведения документ :" + Строка(ТекДок));
Исключение
Сообщить("Невозможно отменить проведение("+Строка(ТекДок)+"), т.к.:");
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЕсли;
КонецЦикла
КонецПроцедуры
Поделиться в соц. сетях


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.
Простите за всплывающее окно, но мы обязаны предупредить, что наш сайт использует куки-файлы. Это помогает нам быть лучше и полезнее для вас.