Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 // Траб - Таблица значений с данными
      
// Диаграмма - ЭлементыФормы.Диаграмма
Процедура ПостроитьДиаграмму(Траб,Диаграмма)

Для Каждого Колонка из Траб.Колонки Цикл
Если Траб.Колонки.Индекс(Колонка) <> 0 Тогда
Диаграмма.Серии.Добавить(Колонка.Имя);
КонецЕсли;
КонецЦикла;

Для Каждого СтрТраб из Траб Цикл
Точка=Диаграмма.Точки.Добавить(СтрТраб.Получить(0));
Индекс=0;
Для Каждого Серия из Диаграмма.Серии Цикл
Индекс=Индекс+1;
Диаграмма.УстановитьЗначение(Точка,Серия,СтрТраб.Получить(Индекс));
КонецЦикла;
КонецЦикла;
КонецПроцедуры

Строить теперь можно и в макете и в форме.
gwa. Григорьев В.


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.