ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Создание журнала с закладками, причем в справочнике можно задать каждой закладке любое название. Создавал в конфигурациях «Бухгалтерский учет» и «Торговля и Склад». Выглядит это так:
а справочник:
1. Создаем новый справочник.Новый1
где, уровень = 1, длина кода = 10, длина наименования = 50. серии кодов = в пределах подчинения, тип кода = текстовый, основное представление = в виде наименования.
Редактируем форму списка:
Добавляем 2 кнопки: Заполнить, Применить.
В модуль:
Код 1C v 7.x
 Процедура Заполнить()
      
Спр = СоздатьОбъект("Справочник.Новый1");
Для Х = 1 По Метаданные.Документ() Цикл
ИдДок = Метаданные.Документ(Х).Идентификатор;
Если Спр.НайтиПоНаименованию(ИдДок) = 0 Тогда
Спр.Новый();
Спр.Наименование = ИдДок;
Спр.Записать();
КонецЕсли;
КонецЦикла;
КонецПроцедуры

Процедура Применить()
НачатьТранзакцию();
Спр = СоздатьОбъект("Справочник.Новый1");
Х = 0;
Док = СоздатьОбъект("Документ");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент() = 1 Цикл
ВидДок = Док.Вид();
Если Спр.НайтиПоНаименованию(ВидДок) = 1 Тогда
Док.ДляОтбора = Спр.Код;
Док.Записать();
КонецЕсли;
Х = Х + 1;
Состояние(Х);
КонецЦикла;
ЗафиксироватьТранзакцию();
КонецПроцедуры


2. В Документы, Общие реквезиты добавляем «ДляОтбора» где: Тип значения = строка и длина = 10 , в Дополнительные стоит галочка «Отбор».

3. В «Журналах» копируем «Общий» и в его модуле пишем:
Код 1C v 7.x
 Процедура ПриОткрытии()
      
ЗакладкиОтбора("ДляОтбора");
КонецПроцедуры //ПриОткрытии


4. Заходим в режиме Предприятия, открываем созданный нами справочник и заполняем его. Называем закладки и жмем «Применить», открываем Журнал и пользуемся :)


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.