Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Поиск в DBF файле по индексу

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 7.x
 ДБФ=СоздатьОбъект("XBase");
      
ДБФ.ДобавитьПоле("DATE","D",0,0);
Дбф.ДобавитьИндекс("INDEX","DTOS(DATE)",0,0,"<");
//Дбф.ДобавитьИндекс("INDEX","DTOS(DATE)",0,0,"Пустая строка"); //DTOS !!!
// где DTOC() - "ММ/ДД/ГГ" или DTOS() - "ГГГГММДД"
ДБФ.СоздатьФайл("c:\test.dbf","c:\test.cdx");
Для ТекДата='01.09.05' По '10.09.05' Цикл
Дбф.Добавить();
Дбф.DATE=ТекДата;
ДБФ.Записать();
КонецЦикла;
//ДБФ.КодоваяСтраница(0);
ДБФ.ТекущийИндекс("INDEX");
Для ТекДата='01.09.05' По '10.09.05' Цикл
ДБФ.Ключ.DATE = ТекДата;
Если ДБФ.НайтиПоКлючу(0)=1 Тогда
Сообщить(ТекДата);
КонецЕсли;
КонецЦикла;
ДБФ.ЗакрытьФайл();


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.