Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 //Находит строку и начинает пересчет вверх по узлам.
      
Процедура ПересчитатьВсеДерево(дз_стр)
для каждого стр из дз_стр.Строки Цикл
Если стр.строки.количество()>0 тогда
ПересчитатьВсеДерево(стр);
Иначе
ПересчетСуммДерева(стр);
прервать;
КонецЕсли;
КонецЦикла;
Конецпроцедуры

Процедура ПересчетСуммДерева(ТекСтрока)
Родитель=ТекСтрока.Родитель;
Если Родитель=Неопределено Тогда
Возврат;
КонецЕсли;
родитель.НазначенныйФонд=родитель.Строки.Итог("СуммаЧегото");
родитель.КТУ=Формат(родитель.Строки.Итог("СреднийПроцентДляУзлов")/Родитель.Строки.Количество(),"ЧДЦ=2");
ПересчетСуммДерева(Родитель);
КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.