ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 Выборка = Справочники.Сотрудники.Выбрать();
      
//или Выборка = Справочники.Сотрудники.ВыбратьИерархически();
Пока выборка.Следующий() = 1 Цикл
... //действия с очередным элементом
...Сообщить("Сотрудник " + выборка.Наименование);
КонецЦикла;

//А через запрос так:
Запрос = Новый Запрос("
|ВЫБРАТЬ
| Ссылка,
| Наименование
|ИЗ
| Справочник.Номенклатура
|АВТОУПОРЯДОЧИВАНИЕ");

Результат = Запрос.Выполнить().Выбрать();

Пока Результат.Следующий() Цикл
Наименование = Результат.Наименование;
КонецЦикла;


Код 1C v 7.x
 
      
// Обход элементов справочника
Спр = СоздатьОбъект("Справочник.Материалы");
Спр.ВыбратьЭлементы();
Пока Спр.ПолучитьЭлемент() = 1 Цикл
// Дальнейшие действия с Спр.ТекущийЭлемент()
сообщить("Наименование "+спр.Наименование+" Код "+спр.код);
КонецЦикла;

//А через запрос так:
Запрос = СоздатьОбъект("Запрос");
ТекстЗапроса ="
|Период с Дата1 по Дата2;
|Обрабатывать НеПомеченныеНаУдаление;
|Спр = Справочник.Материалы.ТекущийЭлемент;
|Группировка Спр упорядочить по Спр.Наименование;";
Если Запрос.Выполнить(ТекстЗапроса) = 0 Тогда
Предупреждение("Запрос по элементам справочника не выполнился!");
Возврат;
КонецЕсли;
// Теперь вся выборка находится в объекте "Запрос"


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.