ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 7.x
 
      
Процедура ПечатьВWord()
wrd=создатьобъект("word.application");
wrd.documents.add("D:\doc.dot");
wrd.visible=1;
wrd.documents(1).tables(1).cell(1,2).range.text = НомерДок;
wrd.documents(1).tables(1).cell(1,4).range.text = ДатаДок;
wrd.documents(1).tables(1).cell(2,2).range.text = Склад.Наименование;
wrd.documents(1).tables(1).cell(3,2).range.text = Получатель.Наименование;
ВыбратьСтроки();
n=КоличествоСтрок() ;
Для i=1 по n-1 Цикл
wrd.documents(1).tables(2).rows.add(wrd.documents(1).tables(2).rows(2).range)
КонецЦикла;
стр = 2;
Пока ПолучитьСтроку()=1 Цикл
wrd.documents(1).tables(2).cell(стр,1).range.text = НомерСтроки;
wrd.documents(1).tables(2).cell(стр,2).range.text =Строка(Товар);
wrd.documents(1).tables(2).cell(стр,4).range.text =Строка(Цена);
wrd.documents(1).tables(2).cell(стр,3).range.text =Строка(Количество);
wrd.documents(1).tables(2).cell(стр,5).range.text =Строка(Сумма);
стр=стр+1;
КонецЦикла;
СуммаДокумента = Итог("Сумма");
wrd.documents(1).tables(2).cell(стр,5).range.text =Строка(СуммаДокумента);
КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.