Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проконсультироваться
со специалистом 1С

Консультироваться

На форме отчета находится поле списка, связанное с реквизитом списком значений.
Нужно:
1) чтоб при нажатии на кнопку Подбор на форме отчета открывалась форма справочника
2) при выборе элементов этого справочника они попадали в список значений в форме отчета и отображались в поле списка.
Как это сделать?


Код 1C v 8.х
 // сзВодители - тот самый список значений,
      
// Справочники.Водители - справочник, откуда надо добавлять данные в список

// Кнопка Подбор:
Процедура ДобавитьВодителяНажатие(Элемент)
ФормаПодбора = Справочники.Водители.ПолучитьФормуСписка(,ЭтаФорма);
ФормаПодбора.РежимВыбора = Истина;
ФормаПодбора.ЗакрыватьПриВыборе = Ложь;
Если Не ФормаПодбора.Открыта() Тогда
ФормаПодбора.Открыть();
КонецЕсли;
КонецПроцедуры

// ОбработкаВыбора для формы со Списком Значений
Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
сзВодители.Добавить(ЗначениеВыбора, ЗначениеВыбора.Наименование, Истина);
КонецПроцедуры

Как видите, владельцем формы, открываемой для подбора служит не отдельный элемент формы отчета, а вся форма отчета.

Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.