ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Функция осуществляет сортировку числового ряда (в массиве) от малого к большему [url=http://ru.wikipedia.org/wiki/Сортировка_пузырьком]методом "пузырька"[/url] Область применения достаточно широка.

Код 1C v 8.х
 
      
Функция СортировкаПузырьком(МассивЭлементов) Экспорт
// Количество просмотров массива - по количеству числа его элементов
Для просмотр = 0 По МассивЭлементов.Количество()-1 Цикл
// Собственно, просмотр массива
Для индекс = 0 По МассивЭлементов.Количество()-1 Цикл
// Если достигли конца массива то прервём цикл,
// чтобы не выполнять условие ниже
Если индекс = МассивЭлементов.Количество()-1 Тогда
Прервать;
КонецЕсли;
// Сравнение элементов и их перестановка (если требуется)
Если МассивЭлементов[индекс] > МассивЭлементов[индекс+1] Тогда
СтаршийЭлемент = МассивЭлементов[индекс];
МладшийЭлемент = МассивЭлементов[индекс+1];
МассивЭлементов[индекс] = МладшийЭлемент;
МассивЭлементов[индекс+1] = СтаршийЭлемент;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Возврат МассивЭлементов;
КонецФункции


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.