Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 Процедура НайтиФайлыПоПодпапкам(НайденныеФайлы, Каталог, Маска)
      
Если НайденныеФайлы = Неопределено Тогда
НайденныеФайлы = Новый Массив;
КонецЕсли;
Путь = Каталог;
МассивФайлов = НайтиФайлы(Путь, Маска);
Для Каждого НайденныйФайл Из МассивФайлов Цикл
НайденныеФайлы.Добавить(НайденныйФайл);
КонецЦикла;
МассивКаталогов = НайтиФайлы(Путь, "*");
Для Каждого Папка Из МассивКаталогов Цикл
Попытка
Если Папка.ЭтоКаталог() Тогда
НайтиФайлыПоПодпапкам(НайденныеФайлы, Папка.ПолноеИмя, Маска);
КонецЕсли;
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;
КонецЦикла;
КонецПроцедуры

а в 8.2 достаточно:
Код 1C v 8.2 УП
 НайденныеФайлы = НайтиФайлы(КаталогПоиска, Маска, Истина); 


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.