ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Установленный монопольный режим позволит пользователю быть единственным пользователем базы, пока он установлен. Однако сам монопольный режим можно установить только в том случае, если на момент установки пользователь был единственным!
Установка монопольного режима
Код 1C v 8.х
 Попытка
      
УстановитьМонопольныйРежим(Истина);
Исключение
Предупреждение("К базе подключены пользователи.Монопольный режим установить невозможно!", 7);
КонецПопытки;


Как видите, если применение процедуры работы с информационной базой УстановитьМонопольныйРежим() приводит к ошибке, приходится с этим смириться. Хотя если захотите обеспечить выход других пользователей из системы, в настоящем издании есть пример того, как этого добиться: Как принудительно завершить работу всех пользователей информационной базы ?».
Кроме самой установки монопольного режима можно еще, например, убедиться, что в текущий момент работа идет в монопольном режиме:

Проверка монопольного режима
Код 1C v 8.х
 Если МонопольныйРежим() Тогда
      
Сообщить("Монопольный режим установлен");
КонецЕсли;


Или же снять монопольный режим (Отмена монопольного режима):
Код 1C v 8.х
 УстановитьМонопольныйРежим(Ложь); 




В 1С 7.7, режим «Монопольно» присутствует только в сетевых версиях 1С. Если же у Вас не сетевая версия, то Вы будете по умолчанию заходить монопольно – Вас об этом даже не спросят.
Для определения режима работы существует специальный метод: МонопольныйРежим(). Возвращаемое значение: Число 1 — если программа запущена в монопольном режиме; Число 0 — если программа запущена в сетевом режиме. Небольшой пример:
Код 1C v 7.x
 Процедура Сформировать()
      
Если МонопольныйРежим()=1 Тогда
ВыгрузитьДанные();
Иначе
Предупреждение("Выгрузку данных необходимо производить в монопольном режиме");
Возрат;
КонецЕсли;
КонецПроцедуры


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.