ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Как программно свернуть/развернуть дерево значений на управляемой форме? Желательно &НаКлиенте.
Код 1C v 8.2 УП
 КоллекцияЭлементовДерева=ДеревоНоменклатуры.ПолучитьЭлементы();
      
//Свернуть дерево
Для Каждого Строка Из КоллекцияЭлементовДерева Цикл
ИдентификаторСтроки=Строка.ПолучитьИдентификатор();
Элементы.ДеревоНоменклатуры.Свернуть(ИдентификаторСтроки);
КонецЦикла;

//Развернуть дерево
Для Каждого Строка Из КоллекцияЭлементовДерева Цикл
ИдентификаторСтроки=Строка.ПолучитьИдентификатор();
Элементы.ДеревоНоменклатуры.Развернуть(ИдентификаторСтроки);
КонецЦикла;




Для выделенной, текущей строки:
Код 1C v 8.х
 // Разворот текущей строки в дереве:
      
Строка = ЭлементыФормы.ТабличноеПоле.ТекущаяСтрока;
ЭлементыФормы.ТабличноеПоле.Развернуть(Строка, Истина);

// Определим, развернут ли узел дерева в указанной строке.
УзелРазвернут = ЭлементыФормы.ТабличноеПоле.Развернут(Строка);
Если УзелРазвернут Тогда
// Если Развернут, то Свернуть
ЭлементыФормы.ТабличноеПоле.Свернуть(Строка);
КонецЕсли;


Код 1C v 8.х
 //перебором свернуть все Выделенные строки дерева Табличного поля
      
Для каждого Строка Из ЭлеменетыФормы.ТабличноеПоле1.ВыделенныеСтроки Цикл
ЭлементыФормы.ТабличноеПоле.Свернуть(Строка);
КонецЦикла;


Хотя конечно есть Ctrl+Shift+"+" и Ctrl+Shift+"-".

P.S. Для Табличного поля с галочкой Дерево(отображающего справочник), перебрать строки НЕВОЗМОЖНО!!!
Примеры вида:
Код 1C v 8.х
 Для каждого Строка Из ЭлементыФормы.тпОбъекты.Строки Цикл
        
// или
Для каждого Строка Из ЭлементыФормы.тпОбъекты.ТекущаяСтрока.Строки Цикл
ЭлементыФормы.тпОбъекты.Свернуть(Строка);
КонецЦикла;
- НЕ РАБОТАЮТ!!!
Для СправочникСписок (ДокументСписок) итератора нет. Это не коллекция значений, перебрать не сможете. Дерево здесь ни при чем.
Можно работать со строками либо через ПриПолученииДанных (предпочтительнее по скорости), либо ПриВыводеСтроки.


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.