Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проконсультироваться
со специалистом 1С

Консультироваться

На форме в табличное поле добавим Колонку (Имя - НачальноеСальдо, Данные - Пусто и все остальное тоже) и колонку КонечноеСальдо
Зайдем в свойства Табличного поля и в событиях определим процедуру при выводе строки: ДействиеПриВыводеСтроки

А в модуле напишем:
Код 1C v 8.х
 
      
Процедура ЗарплатаПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
//Укажем фильтр получения остатков
Фильтр = Новый Структура;
Фильтр.Вставить("ФизЛицо",ДанныеСтроки.ФизЛицо);
// по подразделению не надо
//Фильтр.Вставить("Подразделение", ДанныеСтроки.Подразделение);
//Остаток до документа
Попытка
НачСальдо = РегистрыНакопления.Взаиморасчеты.Остатки(Новый Граница(Дата, ВидГраницы.Исключая),Фильтр,"ФизЛицо","ВзаимРасчет")[0].ВзаимРасчет;
Исключение // остатка нет
НачСальдо = 0;
КонецПопытки;
//Остаток после документа
Попытка
КонСальдо = РегистрыНакопления.Взаиморасчеты.Остатки(Новый Граница(Дата, ВидГраницы.Включая),Фильтр,"ФизЛицо","ВзаимРасчет")[0].ВзаимРасчет;
Исключение // остатка нет
КонСальдо = 0;
КонецПопытки;

ОформлениеСтроки.Ячейки.НачальноеСальдо.ОтображатьТекст = Истина;
ОформлениеСтроки.Ячейки.НачальноеСальдо.Текст = ?(НачСальдо=0,"",НачСальдо);
ОформлениеСтроки.Ячейки.КонечноеСальдо.ОтображатьТекст = Истина;
ОформлениеСтроки.Ячейки.КонечноеСальдо.Текст = ?(КонСальдо=0,"",КонСальдо);

//Добавим цветовое оформление, чтобы выделить минусовые остатки
Если НачСальдо < 0 Тогда
ОформлениеСтроки.Ячейки.НачальноеСальдо.ЦветФона = Новый Цвет(255, 131, 131);
Иначе
ОформлениеСтроки.Ячейки.НачальноеСальдо.ЦветФона = Новый Цвет(255, 255, 231);
КонецЕсли;
Если КонСальдо < 0 Тогда
ОформлениеСтроки.Ячейки.КонечноеСальдо.ЦветФона = Новый Цвет(255, 131, 131);
Иначе
ОформлениеСтроки.Ячейки.КонечноеСальдо.ЦветФона = Новый Цвет(255, 255, 231);
КонецЕсли;
КонецПроцедуры


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.