Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Как реализовать код в зависимости от режима выполнения (клиент, сервер, внешнее соединение)?

Проконсультироваться
со специалистом 1С

Консультироваться

Если алгоритм должен выполняться по-разному в зависимости от места выполнения процедуры, то можно воспользоваться инструкциями препроцессора:

Код 1C v 8.х
 #Если ВнешнееСоединение Тогда
      

// Фрагмент кода, который должен выполняться в сессии внешнего соединения.
// ...

#КонецЕсли

#Если Клиент Тогда

// Фрагмент кода, который должен выполняться на клиентском месте.
// ...

#КонецЕсли

#Если Сервер Тогда

// Фрагмент кода, который должен выполняться на сервере.
// ...

#КонецЕсли


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.