ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Просто открыть:
Код 1C v 8.х
 // Получить форму выбора справочника как подчиненную форме документа 
      
ФормаСписка = Справочники.Номенклатура.ПолучитьФормуСписка( , ЭтаФорма);
// Открыть полученную форму
ФормаСписка.Открыть();



Открыть для выбора элемента:
Код 1C v 8.х
 ФормаВыбора = Справочники.Номенклатура.ПолучитьФормуВыбора( , ЭтаФорма); 
      
ФормаВыбора.Заголовок = "Выберите товар!";
Выбрано = ФормаВыбора.ОткрытьМодально();


Открыть справочник для выбора элемента и установить отбор:
Код 1C v 8.х
 // Если Отобрать = Истина, то откроется выборка справочника без элементов у которых ГруппыПользователей.ВсеПользователи
      
Если Отобрать Тогда
ФормаВыбора = Справочники.ГруппыПользователей.ПолучитьФормуВыбора();
ФормаВыбора.Отбор.Ссылка.Установить(Справочники.ГруппыПользователей.ВсеПользователи);
ФормаВыбора.Отбор.Ссылка.ВидСравнения = ВидСравнения.НеРавно;
Иначе
ФормаВыбора = Справочники.Пользователи.ПолучитьФормуВыбора();
КонецЕсли;
// укажем что выбирать только элементы
ФормаВыбора.ПараметрВыборГруппИЭлементов = ИспользованиеГруппИЭлементов.Элементы;
ВыбранноеЗначение = ФормаВыбора.ОткрытьМодально();



Примеры использования событий(Вывели на форму поле елемента справочника, в его свойствах есть события)
Код 1C v 8.х
 Процедура ПолеВводаНачалоВыбора(Элемент, СтандартнаяОбработка) 
      

// Запретить стандартную обработку.
СтандартнаяОбработка = Ложь;

// Получить форму выбора справочника как подчиненную полю ввода.
ФормаВыбора = Справочники.Номенклатура.ПолучитьФормуВыбора( , Элемент);

// Открыть полученную форму
ФормаВыбора.Открыть();

КонецПроцедуры

Процедура ПолеВводаОбработкаВыбора(Элемент, ВыбранноеЗначение, СтандартнаяОбработка)
// Отключить стандартную обработку (при необходимости).
СтандартнаяОбработка = Ложь;

ПолученноеЗначение = ВыбранноеЗначение;
// Дальнейшая обработка значения.
КонецПроцедуры


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.