ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

<fieldset><legend style="color: #001a34;">Код 1C v 8.х</legend><pre><code class="1c8"> //п_Текст - ТекстЗапроса... вернётся соответственно ТЗ<br>Функция Прямой_запрос_к_jabber(п_Текст) Экспорт<br>    л_ТЗ = Новый ТаблицаЗначений;<br>    л_число_попыток = 0;<br>    л_Запрос_выполнен = Ложь;<br>    Пока (л_Запрос_выполнен = Ложь) И (л_число_попыток <= 3) Цикл<br>        Если (гл_Соединение_jb.State = 0) Или (гл_Соединение_jb.DefaultDatabase <> "log_1c") Тогда<br>            гл_Соединение_jb = "";<br>            л_Параметры_соединения = "DRIVER={MySQL ODBC 5.1 Driver};OPTION=3;DATABASE=BAZADANNIH_IMYA;PWD=PAROLLLLL;PORT=3306;SERVER=ip_adres_servera;UID=admin";<br>            гл_Соединение_jb = Новый COMОбъект("ADODB.Connection");<br>            Попытка<br>                гл_Соединение_jb.Open(л_Параметры_соединения);<br>            Исключение<br>            КонецПопытки;<br>        КонецЕсли;<br>        <br>        л_Команда = Новый COMОбъект("ADODB.Command");<br>        л_Команда.ActiveConnection = гл_Соединение_jb;<br>        л_Команда.CommandText = п_Текст;<br>        л_Команда.CommandType = 1;<br>        <br>        л_Набор_записей = Новый COMОбъект("ADODB.Recordset");<br>        л_Набор_записей.CursorType = 3;<br>        л_число_попыток = л_число_попыток + 1;<br>        Попытка<br>            л_Набор_записей = л_Команда.Execute();<br>            л_Запрос_выполнен = Истина;<br>        Исключение<br>        КонецПопытки;<br>    КонецЦикла;<br>    Если (л_Запрос_выполнен = Ложь) Тогда<br>        Сообщить(ОписаниеОшибки());<br>        Возврат(л_ТЗ);<br>    Иначе<br>        л_Число_колонок = л_Набор_записей.Fields.Count - 1;<br>        Если (л_Число_колонок > -1) Тогда<br>            Для Ф = 0 По л_Число_колонок Цикл<br>                л_Колонка_добавлена = Ложь;<br>                л_Префикс = "";<br>                л_сч = 0;<br>                Пока (л_Колонка_добавлена = Ложь) Цикл<br>                    Попытка<br>                        л_ТЗ.Колонки.Добавить(л_Префикс + л_Набор_записей.Fields(Ф).Name);<br>                        л_Колонка_добавлена = Истина;<br>                    Исключение<br>                        л_Префикс = ?(л_сч = 0, "_", "_" + л_сч + "_");<br>                        л_сч = л_сч + 1;<br>                    КонецПопытки;<br>                КонецЦикла;<br>            КонецЦикла;<br>            Если (л_Набор_записей.EOF() = Истина) И (л_Набор_записей.BOF() = Истина) Тогда<br>            Иначе<br>                л_Набор_записей.MoveFirst();<br>                Пока (л_Набор_записей.EOF() = 0) Цикл<br>                    л_стр = л_ТЗ.Добавить();<br>                    Для Ф = 0 По л_Число_колонок Цикл<br>                        л_стр[Ф] = л_Набор_записей.Fields(Ф).Value;<br>                    КонецЦикла;<br>                    л_Набор_записей.MoveNext();<br>                КонецЦикла;<br>            КонецЕсли;<br>        КонецЕсли;<br>        Попытка<br>            л_Набор_записей.Close();<br>        Исключение<br>        КонецПопытки;<br>        Возврат(л_ТЗ)<br>    КонецЕсли;<br>КонецФункции<br>   </code></pre></fieldset><br>Немного кривое решение... но как шаблон вполне<br><b> Megas </b>


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.