ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 7.x
 // Пример 1
      
Для к = 1 по Метаданные.РеквизитПроводки()
Сообщить(Метаданные.РеквизитПроводки(к).Идентификатор);
КонецЦикла;


Код 1C v 7.x
 // Пример 2
      
СписокРеквизитов = СоздатьОбъект("СписокЗначений");
// реквизиты формы операции
СписокРеквизитов.ДобавитьЗначение("ДатаОперации");
СписокРеквизитов.ДобавитьЗначение("НомерДок");
СписокРеквизитов.ДобавитьЗначение("СуммаОперации");
СписокРеквизитов.ДобавитьЗначение("Содержание");

// Дополнительные реквизиты операции
Для М1 = 1 По Метаданные.РеквизитОперации() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.РеквизитОперации(М1).Идентификатор);
КонецЦикла;

// Общие реквизиты документов
Для М1 = 1 По Метаданные.ОбщийРеквизитДокумента() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.ОбщийРеквизитДокумента(М1).Идентификатор);
КонецЦикла;

СписокРеквизитов.ДобавитьЗначение("НомерПроводки");
СписокРеквизитов.ДобавитьЗначение("ПланСчетов");
СписокРеквизитов.ДобавитьЗначение("СчетДт");
СписокРеквизитов.ДобавитьЗначение("СчетКт");
СписокРеквизитов.ДобавитьЗначение("Субконто");
СписокРеквизитов.ДобавитьЗначение("СубконтоДт");
СписокРеквизитов.ДобавитьЗначение("СубконтоКт");

Для М1 = 1 По Метаданные.МаксимальноеКоличествоСубконто Цикл
СписокРеквизитов.ДобавитьЗначение("Субконто" + М1);
СписокРеквизитов.ДобавитьЗначение("СубконтоКт" + М1);
СписокРеквизитов.ДобавитьЗначение("СубконтоДт" + М1);
КонецЦикла;


СписокРеквизитов.ДобавитьЗначение("Валюта");
СписокРеквизитов.ДобавитьЗначение("Курс");
СписокРеквизитов.ДобавитьЗначение("Количество");
СписокРеквизитов.ДобавитьЗначение("ВалСумма");
СписокРеквизитов.ДобавитьЗначение("Сумма");
СписокРеквизитов.ДобавитьЗначение("НомерСтроки");

// Дополнительные реквизиты проводки
Для М1 = 1 По Метаданные.РеквизитПроводки() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.РеквизитПроводки(М1).Идентификатор);
КонецЦикла;

// журнал операций
СписокРеквизитов.ДобавитьЗначение("ВидДок");
СписокРеквизитов.ДобавитьЗначение("ВремяОперации");

// Дополнительные графы журнала операций
Для М1 = 1 По Метаданные.ГрафаЖурналаОпераций() Цикл
СписокРеквизитов.ДобавитьЗначение(Метаданные.ГрафаЖурналаОпераций(М1).Идентификатор);
КонецЦикла;


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.