Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.2 УП
 &НаКлиенте
      
Процедура СообщитьИмяПользователя(Команда)
// Вставить содержимое обработчика.
Сообщить(ПолучитьПользователя());

КонецПроцедуры

&НаСервере
Функция ПолучитьПользователя()
Перем ВыбПользователь;
ВыбПользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
Возврат ВыбПользователь.Имя;
КонецФункции;

// или так:
Сообщить(ИмяПользователя());
Сообщить(ПолноеИмяПользователя());



Код 1C v 8.х
 ИмяПользователя = ИмяПользователя(); 
      
Если ПустаяСтрока(ИмяПользователя) Тогда
// пользователь не авторизовался
ИмяПользователя = "НеАвторизован";
Иначе
ИмяПользователя = ПолноеИмяПользователя();
КонецЕсли;



Код 1C v 7.x
 Сообщить(ИмяПользователя())
      
// Сообщит: ПупкинВася

Сообщить(ПолноеИмяПользователя())
// Сообщит: Пупкин Василий Петрович


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.