ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.2 УП
 &НаКлиенте
      
Процедура СообщитьИмяПользователя(Команда)
// Вставить содержимое обработчика.
Сообщить(ПолучитьПользователя());

КонецПроцедуры

&НаСервере
Функция ПолучитьПользователя()
Перем ВыбПользователь;
ВыбПользователь = ПользователиИнформационнойБазы.ТекущийПользователь();
Возврат ВыбПользователь.Имя;
КонецФункции;

// или так:
Сообщить(ИмяПользователя());
Сообщить(ПолноеИмяПользователя());



Код 1C v 8.х
 ИмяПользователя = ИмяПользователя(); 
      
Если ПустаяСтрока(ИмяПользователя) Тогда
// пользователь не авторизовался
ИмяПользователя = "НеАвторизован";
Иначе
ИмяПользователя = ПолноеИмяПользователя();
КонецЕсли;



Код 1C v 7.x
 Сообщить(ИмяПользователя())
      
// Сообщит: ПупкинВася

Сообщить(ПолноеИмяПользователя())
// Сообщит: Пупкин Василий Петрович


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.