ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

1. Создаешь внешнюю обработку или отчет в ней форме пишешь
Код 1C v 8.х
 "ПланыОбмена.УстановитьГлавныйУзел(Неопределено);" 

2. Сохраняешь обработку.
3. Закрываешь конфигуратор
4. Запускаешь пользовательский режим.
5. Запускаешь обработку.


Еще Вариант кода:
Код 1C v 8.х
 Процедура ОтключитьГлавныйУзелНажатие(Элемент) 
        
Если ПланыОбмена.ГлавныйУзел()<> Неопределено Тогда
СохранитьЗначение("ВосстановитьЗначениеГлавногоУзлаВПодчиненном", ПланыОбмена.ГлавныйУзел());
ПланыОбмена.УстановитьГлавныйУзел(Неопределено);
КонецЕсли;
Предупреждение("Главный узел отключен");
КонецПроцедуры

Процедура ВосстановитьГлавныйУзелНажатие(Элемент)
Если ПланыОбмена.ГлавныйУзел()= Неопределено Тогда
ПланыОбмена.УстановитьГлавныйУзел(ВосстановитьЗначение("ВосстановитьЗначениеГлавногоУзлаВПодчиненном"));
КонецЕсли;
Предупреждение("Главный узел восстановлен");
КонецПроцедуры


Готовая обработка Отключить Восстановить Подчиненный Узел От Главный Узел Скачивать файлы может только зарегистрированный пользователь!


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.