ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.2 УП
 &НаСервереБезКонтекста
      
Функция ПолучитьТипКлиента()
Соединения=ПолучитьСоединенияИнформационнойБазы();
ТекущееСоединение=Соединения.Получить(НомерСоединенияИнформационнойБазы()-1);
Если ТекущееСоединение=Неопределено Тогда
Возврат "";
КонецЕсли;
Возврат (ПредставлениеПриложения(ТекущееСоединение.ИмяПриложения));
КонецФункции

&НаКлиенте
Процедура Тест(Команда)
Сообщить(ПолучитьТипКлиента());
КонецПроцедуры

еще вариант:
Код 1C v 8.2 УП
 Функция ПолучитьТекущуюСредуВыполнения() Экспорт
      

#Если ТолстыйКлиентОбычноеПриложение ИЛИ ТолстыйКлиентУправляемоеПриложение Тогда

Возврат "Толстый клиент";
#ИначеЕсли Сервер Тогда

Возврат "Сервер";
#ИначеЕсли ВнешнееСоединение Тогда

Возврат "Внешнее соединение";
#ИначеЕсли ТонкийКлиент Тогда

Возврат "Тонкий клиент";
#ИначеЕсли ВебКлиент Тогда

Возврат "Веб-клиент";
#Иначе

Возврат "Ошибка определения среды выполнения";
#КонецЕсли

КонецФункции


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.