Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Как определить в каком режиме запущена программа(тонкий, толстый, web-клиент)?

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.2 УП
 &НаСервереБезКонтекста
      
Функция ПолучитьТипКлиента()
Соединения=ПолучитьСоединенияИнформационнойБазы();
ТекущееСоединение=Соединения.Получить(НомерСоединенияИнформационнойБазы()-1);
Если ТекущееСоединение=Неопределено Тогда
Возврат "";
КонецЕсли;
Возврат (ПредставлениеПриложения(ТекущееСоединение.ИмяПриложения));
КонецФункции

&НаКлиенте
Процедура Тест(Команда)
Сообщить(ПолучитьТипКлиента());
КонецПроцедуры

еще вариант:
Код 1C v 8.2 УП
 Функция ПолучитьТекущуюСредуВыполнения() Экспорт
      

#Если ТолстыйКлиентОбычноеПриложение ИЛИ ТолстыйКлиентУправляемоеПриложение Тогда

Возврат "Толстый клиент";
#ИначеЕсли Сервер Тогда

Возврат "Сервер";
#ИначеЕсли ВнешнееСоединение Тогда

Возврат "Внешнее соединение";
#ИначеЕсли ТонкийКлиент Тогда

Возврат "Тонкий клиент";
#ИначеЕсли ВебКлиент Тогда

Возврат "Веб-клиент";
#Иначе

Возврат "Ошибка определения среды выполнения";
#КонецЕсли

КонецФункции


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.