ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

В 8.1 есть такая встроенная функция, а в 8.0 про нее почему-то забыли, исправим это недоразумение:

Код 1C v 8.х
 
      
Функция ЗначениеЗаполнено(Значение) Экспорт
Результат = Истина;
ТипЗначения = ТипЗнч(Значение);

Если Значение = Неопределено Тогда
Результат = Ложь;
ИначеЕсли Значение = NULL Тогда
Результат = Ложь;
ИначеЕсли ТипЗначения = Тип( "Строка" ) Тогда
Если СокрЛП( Значение ) = "" Тогда
Результат = Ложь;
КонецЕсли;
ИначеЕсли ТипЗначения = Тип( "Число" ) Тогда
Если Значение = 0 Тогда
Результат = Ложь;
КонецЕсли;
ИначеЕсли ТипЗначения = Тип( "Дата" ) Тогда
Если Значение = Дата( '00010101' ) Тогда
Результат = Ложь;
КонецЕсли;
ИначеЕсли ТипЗначения = Тип( "Булево" ) Тогда
Результат = Истина;
ИначеЕсли ТипЗначения = Тип( "РежимПроведенияДокумента" ) Тогда
Результат = Истина;
Иначе
Если Значение = Новый( ТипЗначения ) Тогда
Результат = Ложь;
КонецЕсли;
КонецЕсли;
Возврат Результат;
КонецФункции



Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.