ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

Код 1C v 8.х
 
      
// Функция выделяет из имени файла его расширение
//
// Параметры
// ИмяФайла – Строка, содержащая имя файла, неважно с именем каталога или без.
//
// Возвращаемое значение:
// Строка – расширение файла.
//
Функция ПолучитьРасширениеФайла(ИмяФайла) Экспорт

ПозицияПоследнейТочки = 0;
РасширениеФайла = ИмяФайла;

Пока 1 = 1 Цикл

ПозицияПоследнейТочки = Найти(РасширениеФайла, ".");

Если ПозицияПоследнейТочки = 0 Тогда

Прервать;

Иначе

РасширениеФайла = Сред(РасширениеФайла, ПозицияПоследнейТочки + 1)

КонецЕсли;

КонецЦикла;

Возврат ?(РасширениеФайла = ИмяФайла, "", РасширениеФайла);

КонецФункции


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.