ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

+7 (495) 223-32-11

Заказать обратный звонок

8 (800) 775-90-01

Бесплатно по России

Получить

Скорую 1С помощь

Получить

Проконсультироваться
со специалистом 1С

Консультироваться

ОГРН (основной государственный регистрационный номер) — государственный регистрационный номер записи о создании юридического лица либо записи о первом представлении в соответствии с Федеральным законом “О государственной регистрации юридических лиц” сведений о юридическом лице, зарегистрированном до введения в действие указанного Закона (пункт 8 Правил ведения Единого государственного реестра юридических лиц) (см. ОГРН в Википедии).

Структура ОГРН:

* 1 цифра – код, признак ОГРН (всегда равен 1);
* 2 цифры – две последние цифры года внесения записи в государственный реестр;
* 2 цифры – код региона по перечню регионов в 65-й статье Конституции
* 7 цифр – порядковый номер записи от начала года;
* 1 цифра – проверочный код ОГРН;

Что можно узнать зная ОГРН:

1. Год регистрации организации по двум последним цифрам.

2. С некоторой точностью месяц (а может быть и неделю) регистрации организации по порядковому номеру записи.

3. Код региона организации по 65-й статье Конституции.

4. По коду ОГРН может быть получена иная публичная информациия по организации – ИНН, КПП, наименование, адрес из публичного реестра ФНС.

Можно обратить внимание что ИНН и ОГРН отличаются принципами ведения порядковых номеров организаций. Если в ИНН они привязаны к налоговой инспекции, то в ОГРН к году регистрации. Соответственно исходя из возможности по порядковому номеру ИНН определить дату его присвоения, можно говорить что ИНН несёт чуть больше информации (номер инспекции) чем ОГРН.

Код 1C v 8.х
 // Параметры: 
      
// ОГРН - строка - проверяемый основной государственный регистрационный номер
Функция ОГРНсоответствуетТребованиям(Знач ОГРН) Экспорт
Попытка
ОГРНБезВедущихНулей = Формат(ОГРН,"ЧГ=0");
Исключение
Возврат Ложь;
КонецПопытки;
ОГРН = Строка(ОГРНБезВедущихНулей);
Если СтрДлина(ОГРН) <> 13 Тогда
Возврат Ложь;
Иначе
Возврат Истина;//проверка временно отключена
КонецЕсли;
ОГРН12 = Число(Лев(ОГРН, 12));
Если Прав(Формат(ОГРН12%11, "ЧН=0; ЧГ=0"), 1) = Прав(ОГРН, 1) Тогда
Возврат Истина;
Иначе
Возврат Ложь;
КонецЕсли;
КонецФункции


Информация взята с сайта http://helpf.pro


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.