Для отображения персонализированного контента и рекламных сообщений, а также хранения личных настроек на локальном компьютере веб-сайт www.vdgb.ru используют технологию cookie и аналогичные. Продолжив использование наших веб-сайтов, Вы даете согласие на обработку персональных данных, выражаете согласие с Политикой конфиденциальности www.vdgb.ru и применением этих технологий.

ПРОДАЖА И ВНЕДРЕНИЕ 1С

по всей России

Функция проверяет соответствие КПП Контрагента требованиям

Проконсультироваться
со специалистом 1С

Консультироваться

Код причины постановки на учёт (КПП) представляет собой девятизначный цифровой код, который вместе с ИНН организации позволяет однозначно идентифицировать её обособленные подразделения (см. КПП в Википедии).

Структура КПП:

* 4 цифры – код подразделения ФНС России (справочник СОУН);
* 2 цифры – код причины постановки на учёт;
* 3 цифры – порядковый номер постановки на учёт;

В большинстве случаев КПП выглядит как: код подразделения ФНС + 01001 поскольку не так уж много организаций имеют обособленные подразделения.

К недостаткам КПП можно отнести невозможность проверки КПП по контрольной сумме. Максимум можно проверить “разумность” заполнения каждого из его элементов. В общем случае КПП не несёт больше информации чем несёт ИНН, и практически никогда не используется по отдельности в ИНН организации.

Код 1C v 8.х
 // Параметры: 
      
// КПП - строка - проверяемый код причины постановки на учет
Функция КППСоответствуетТребованиям(Знач КПП) Экспорт

Если НЕ ТолькоЦифрыВСтроке(КПП) Тогда
Возврат Ложь;
КонецЕсли;

Если СтрДлина(СтрЗаменить(Строка(КПП), "0", "1")) <> 9 Тогда
Возврат Ложь;
КонецЕсли;

Возврат Истина;

КонецФункции


Заказать обратный звонок

Позвонить
Отправлено! В самое ближайшее время наш менеджер свяжется с Вами.